107 thoughts on “D-Link DNS-325”

  1. First i would like to apologize for my bad English.

    I was wondering if it’s possible install fun_plug on the DNS-325 using the same procedure as on the DNS-320 as they both use the same kernel.

    Currently I own a DNS-323 which has fun_plug, transmission 2.04 and subversion installed. I’m looking to upgrade my DNS-323 to a DNS-325 if it has the same modding possibilities. I’m experiencing some lag in performance on my DNS-323 after I installed the mentioned software.

  2. Thank you for the quick reply 🙂

    Well thats sounds just awsome 🙂 I’m looking forward to putting my hands on the DNS-325

  3. Pingback: malte-germany.de » Blog Archiv » D-Link mit neuem NAS für bis zu 4TB Speicherplatz
  4. Hello,
    I’m considering the DNS-320 (69 pounds in amazon uk), should I wait for the DNS-325? is the performance gap suficient to justify the DNS-325? (i don’t know how much will it cost…)
    Regards

    1. Hello RNFC,

      campare the DNS-325 yourself, there are a number of articles above. If you have specific questions, do not hestitate to ask. But the choice between the DNS-320 and the DNS-325 cannot be done by us. The DNS-325 of course is more expensive (and already available by the way) but also features more ram, faster cpu and faster networkspeed.

      Cheers,
      Uli

  5. Hi Uli,

    Mybe you know, it is possible to take out hard drives from DNS-323 and put it in DNS-325 without loss of data?

    Best regards,

    Vodokotlic

  6. Hi everybody,
    I’m in similar situation like NiRa. I have got DNS-323 Firmware Version: 1.08, where I use Fonz fun_plug 0.5, Transmission-1.75-1.tgz, OpenVpn-2.0.9-1 and others. I had the most information from wiki.dns323.info.

    Now I bought DNS-325 Firmware Version: 1.00, with 2x HDD Hitachi model HDS723020BLA642. I use hard drive configuration RAID 1 (Mirror) so I have just one Volume_1. I disable Auto-Rebuild configuration.

    When I try to install/initialize Fonz fun_plug 0.5, I copied files fun_plug and fun_plug.tgz into the Volume_1 share and I let DNS-325 reboot. But I was surprised no good result (no log file in Volume_1 no telnet access).

    I try to change HDD configuration to one standard HDD Volume_1, copy fun_plug and fun_plug.tgz into the Volume_1, but again no log or telnet access.

    Does anybody have Funz fun_plug on his DNS-325. Could you help me?

    1. For those of you trying this with the DNS-325, don’t forget that paths have changed.

      What was /mnt/HD_a2 on the DNS-323 is /mnt/HD/HD_a2 on the DNS-325.

      I had to make a few changes to my installation.
      The 325 setup is probably more like the DNS-320.

      I had to change store-passwd.sh among other things I can’t remember now.
      I also had problems with running from a USB stick, I believe the filesystem was always getting mounted 777 which means sshd wouldn’t start. I ended up hacking fun_plug.local to chmod the appropriate perms. I used:

      chmod 755 /ffp/etc/ssh
      chmod 644 /ffp/etc/ssh/*
      chmod 600 /ffp/etc/ssh/*_key
      chmod go-w /ffp/var/lib/sshd

      If I remember correctly the permission thing also caused a lot of services to start that I didn’t want. I also added the following to fun_plug.local:

      # Turn OFF the following:

      for unwanted in portmap.sh dnsmasq.sh mysqld.sh unfsd.sh btpd.sh lighttpd.sh kickwebs.sh telnetd.sh svnserve.sh rsyncd.sh
      do
      chmod a-x /ffp/start/$unwanted
      done

      Hope that helps someone.

  7. Hi Uli,

    Are you sure that you can take out the drives from DNS 323 and insert them in DNS 325 without reformating and the drives will be recognized by DNS 325?

    I tried it. but It seems like DNS 325 does not recognize the drives from 323. What do I need to do? Please help.

  8. Has anyone gotten fun_plug to work on a dns-325 with the new beta firmware? I have the files in Volume_1 however telnet never starts up (and fun_plug has the correct new paths), any ideas

  9. Hi Uli,

    I have bought a DNS-325 and connected it to my router (Linksys WAG325N) via the UTP cable but the DNS is not recognized. Any idea how I could fix this?

    Thanks,
    Filip

  10. I have dlink dns 325, I’m trying to watch video files in the box to my TV.

    HOw can I do that…..
    which media player I can use.

    My TV is Panasonic and I also have ROKU

    But, none of these can stream the media over network from Dlink DNS 325 ??? Any tips ? ideas, suggestions ?

  11. I have just bought a DNS-325 and I’m trying to access its from my Mac… without success.

    Some minute ago I found two shared disks but all connection failed.

    How can I access to my NAS ?!? Does exist any installation software for Mac ?

    1. Hi Mauro,

      I’m a Mac user too, unfortunatly there is not a great deal of support for macs with this product.

      After a lot of searching I found that the default ip adress is 192.168.0.32.

      Type this into your web browser and you’ll be able to administrate from there.

      PS – let me know if you manage to get the Local Backup App working. (Timecapsule works great, but for media sharing etc you’ll need to do a separate sync of your media folders, I so far have struggled to set up a scheduled sync)

      Anyway, hope that helps

  12. hello i have just upgraded my nas325 to the beta firmware and installed 2 WD 3tb harddrives and formated them raid1 and all looks fine in the nas’ interface shows both drives and one volume but in windows 7 when i mapped the volume it only shows 699mb?

    any help would be great.

    Q

  13. Hi,

    I´m hesitating in buying a this NAS, and would like to know if you can help me with the following answers:

    I have a lot of movies / music /photo´s and other multimedia files

    Is it easy setup this system to watch movie listen to music in my living room if this NAS in other place???
    I´m asking because I don´t have a clue how this works

    Other question: Once my hdd is full can I place a new one without lossing the data???

    Actual Setup
    I have at home 1 laptop, mac mini in the living room & a windows desktop
    Wireless and ethernet concetion between desktop and living room

    Hope that you can help me with my doubts

    Thanks a lot,

    1. Hello Jorge,

      It is relatively easy to set it up. You cannot replace the harddisk without copying the data from one disk to another.

      Cheers,
      Uli

  14. Sorry to butt in…. I’m setting up the 325 and all seems well… except for the fact that users that i have set deny options for on certain folder are still able to see and have full read/ write access…

    The only thing i can think is that the volume permissions is superseding the folder specific ones?

    But if i remove or deny vol1 permissions the use cannot then map to the drive / folder?

    When users map to the drive it’s asking for user name & passwords and that works fine but everyone is getting full access. I have tried adding groups into the mix but with no success.

    Any help would be great..

    thanks
    Chris

    1. If you remove the Volume_1 Folder, the other permissions should not be tangled. Remove the Volume_1 folder first and then create the others.

      Cheers,
      Uli

      1. Hi Uli,

        I have the same problem, on a DNS-345. I have 2 x 3TB drives, on 1 Volume with Raid 1. In the Network Share page I only see Volume_1, with no sub-folders. I tried deleting the existing Volume_1 share and creating a new one but I still see no subfolder options (there are 2 subfolders under Volume_1 root). What am I doing wrong?

        Regards

        John

  15. Hi
    I had installed a single drive and now have chosen to add a second to increase the overall capacity (ie no RAID). When I add the second drive, the data on the first disappears… when I remove the second drive, the data on the first appears.

    Have I done something wrong in the setup? Help would be greatly appreciated.

    Thanks,
    Rob

  16. Just want to say thank you (Re: 16th Dec 2011)
    All working fine…. as was expected user error (Mine) i was mapping the drive to volume one which or cause everyone had full read/ write permissions.
    Anyway all sorted and working great.

  17. Has anyone every found out if there is a way to add some additional software to allow you to export storage as iSCSI or will this never be possible on this platform?

    1. I would be very interested to know if this is possible with ffp as well. I run an SBS11 domain in my house and it is blocking me from logging into the shares as it insists on inserting the domain in front of the username during authentication.

      I have searched quite a bit and found some leads but really, iSCSI sounds like the best solution here.

      I have fairly recently gone back to a Windows based network from CentOS and perhaps bought the wrong NAS device.

      Alternatively, is there a way to change a GPO to allow the login (even better if it is transparent auth)?

      Odd subnote: I can login to the IP address once I change the Local Security Policy on the clients but still not the DNS name!! I can see the DNS name but authentication fails since it insits on using the domain… That suggests that it is not a DNS issue.

      However, I don’t want to have to manually change every client everytime I wipe a machine (four kids…).

      Any advice would be appreciated!

      KentMc

      1. you might be able to get it working using command line tools in windows (eg. NET USE). This isn’t an insurmountable problem though, I am certain.

        For Samba shares, it seems to either not care about the realm before the username or windows doesn’t actually transmit it. My Windows7 PC (workgroup not domain) still authenticates as “Computername\Username” in the username field yet it works just fine.

        Have another poke at it, try the CLI stuff, and lookup this problem as a general Linux/Samba issue on other forums rather than as something specific to the Sharecenter (which it isn’t)

  18. Can I transfer (Physically move) the hard drives from the DNS-320 into a new DNS-343 without losing any files?

  19. originally i had 2 x 1tb drives in raid 1

    i upgraded today to 2 x 3 tb drives and rebuilt the raid

    bet now my dns-325 is reporting only 900 GB total of space and still only 200 GB remanning like when it was before with the 1 TB drives

    could someone please help me

    1. You must upgrade the firmware to the latest version. I am running 2 x 3TB drives with no issues other than the ones I describe above, which have nothing to do with the storage…

      KentMc

  20. I punt. I’ve spent roughly two hours on this site trying to understand how to install fun_plug on my D-Link 325. I give up. My objective was to allow Oracle to run a goddamn chmod command so I could use the D-Link 325 as shared storage for a cluster configuration. Exactly how many goddamn hours am I supposed to spend installing “fun” plug? I called D-Link asking how to allow a Linux client to run a chmod command on the disk enclosure, and they said, in all their eloquence, “we don’t support Linux” We’re in dumbed-down world folks. Idiocracy is here. I was thrilled someone had developed a kernel for the Dumb-assed DLink 325, but hell if I can get it installed. I’ve ‘tar -xvf’ the goddamn tar file twice, and rebooted twice. I punt. If I must spend a day figuring this goddamn thing out, I’m out.

  21. Michael,

    It needs to go in the root folder of the top-level share, usually called “Volume_1”.

    Perhaps you’ve inadvertently placed it into a subfolder ?

  22. Just got the DNS-325, the main reason was because of compatibility with my existing disks in my DNS-321. That alone saved hours of moving 4TB of data over.

    The performance is WAY better than a DNS-321 but a factor 5. The DNS-321 is quite slow and basic stuff like clicking on a directory and waiting ten seconds for a file list was getting too much.

    Anyways, I followed your fun_plug instructions and have that running too. I had many mods on my DNS 321 running but need a lot less now, especially with native AFP support.

  23. I will take another swing at it tomorrow. I really need a Linux system to be able to run a “chown” command on the D-Link 325, so I can build an Oracle 11g dual node RAC. With the D-Link firmware, chown is apparently disabled. I’m hoping unplug resolves this. Thanks!

    1. You can do this although I think your Oracle integration plan is a little ambitious…

      root@192.168.1.78's password:
      root@Shadow:/mnt/HD/HD_a2/ffp/home/root#

      root@Shadow:/mnt/HD/HD_a2/ffp/home/root# chown
      BusyBox v1.12.1 (2008-09-29 20:38:04 CEST) multi-call binary

      Usage: chown [-RhLHPcvf]... OWNER[[GROUP]] FILE...

      Change the owner and/or group of each FILE to OWNER and/or GROUP

      Options:
      -R Recurse directories
      -h Affect symlinks instead of symlink targets
      -L Traverse all symlinks to directories
      -H Traverse symlinks on command line only
      -P Do not traverse symlinks (default)
      -c List changed files
      -v List all files
      -f Hide errors

      root@Shadow:/mnt/HD/HD_a2/ffp/home/root# touch test_file
      root@Shadow:/mnt/HD/HD_a2/ffp/home/root# ls -lh
      -rw-r--r-- 1 root root 0 May 3 11:55 test_file

      root@Shadow:/mnt/HD/HD_a2/ffp/home/root# chown sshd.sshd test_file
      root@Shadow:/mnt/HD/HD_a2/ffp/home/root# ls -lh
      -rw-r--r-- 1 sshd sshd 0 May 3 11:55 test_file

  24. Hi guys.
    I have a dns-325 running 1.03b and fun plug 0.7. I have installed subversion from http://downloads.zyxel.nas-central.org/Users/Mijzelf/FFP-Stick/packages/0.7/arm/ (and apr-1.4.6-arm-1.txz).
    trying to start svnserve with
    svnserve -d
    just gives me
    svnserve: E000022: Can’t create server socket: Invalid argument
    Looking at netstat doesn’t show anything using the default port (3960). Specifying a port with –listen-port=port doesn’t help
    Can anyone offer anything to move forward please?

      1. I had the same issue. The apr_util package you have uses SOCK_CLOEXEC which is not supported in 0.7’s kernel 2.6.22. Try to download correctly built apr_util from some other place.

        1. Hi sk,

          I’ve recompiled apr with disabled SOCK_CLOEXEC. The issue is that SOCK_CLOEXEC requires a kernel >= 2.6.27. Now fixed.

          Thanks for the Bugreport!

          Best Regards,
          Uli

  25. Hi, i have purchased the nas 325 for the first time, have followed the online guides but when it comes to asking for the admin password on setup it keeps saying login fail, please try again or leave it blank, but i havent put any password at all and if i leave it blank it says the same again over and over , ive tried resetting it but still wont let me go any further … what do i do?

    1. Hi!First of all you must have access to server interface.Probably you must put 10.0.0.60 and access first time to your server interface.If i remember rigth you must put admin and blank password(see the manual for further details).At the next step you set your space,without password(free for all in your network),or set password.Care,because the password which you set must be the same with the windows log in screen password!Finally if you try to access to your partition space you have access without asking you password or something else. 🙂

  26. Does anyone have the “latest” list of compatible hardware drives for the DNS-325? Specifically 2 and 3 TB drives?

    I currently have 2 x 2TB Hitachi drives in a spanning mode to get the 4tb of storage in a DNS-323, and have my movie collection on this. Space getting full and fearful of Hard Drive crash (losing a massive collection like that would be sickening). Want to go to a RAID 1 with 2 x 3tb in the DNS- 325. Which ones work?

      1. THANK YOU for the link. Never found a “user submitted” list, that’s awesome!

        Question about your WD 3TB drives you have:
        What are the model numbers for them?

        How do you have them arranged (RAID 0,1, spanning, etc)?

        1. No problem – glad I could help, as I’m still figuring all this stuff out. I have the WD30EZRX installed, and configured as RAID1. As I said, they seem to work okay – now I just need to figure out why I can’t get the share to mount as AFP rather than SMB on my MacBook Pro. Someone said fun_plug, but that seems to be somewhat over my head…

          1. Did you update your firmware? which version?
            i wouldlike to buy the WD30EZRX but im a bit afraid…

  27. Yeah, I updated to 1.03, and so far so good. In fact, I’m now able to use the iTunes Media server, so that’s a plus.

    1. Hello Flysi3000. I just got my DNS 325 and installed one WD 3TB Caviar Green drive (model WD30EZRX) into one of the bays and its only recognizing my drive as a 750GB drive. I even upgraded to firmware 1.03 and it still only recognizes my 3TB drive as a 750GB drive. I formatted my drive as “Standard”… Does anyone know if that could that be what’s causing the issue? I will try to reformat my drive as RAID 0 or 1 (before I start adding files and buy another accompanying 3TB backup drive) to see if that fixes the DNS 325 to finally recognize this drive as a 3TB.

      1. That’s a great question, and I have no idea why that’s happening. I’m not much of a NAS expert, by the way, but hopefully some of the other smart guys who hang around here will have an answer for you.

        I’m still trying to figure out why the f@ck I can’t connect to my DNS 325 via AFP anymore, and why the hell I get a max transfer rate of ~4MB/s with the thing. It’s borderline useless at this point.

        1. I reformatted my 3TB HDD again (this time AFTER the Firmware update to 1.03) and all is well now and the DNS 325 now recognizes it as a 3TB drive. When I first got the DNS 325 I formatted the WD 3TB Caviar Green drive (as Standard) before doing any of the firmware updates (silly mistake) and I assumed the 1.02 firmware update would fix this and recognize the drive as a 3TB, but I guess doing the firmware update first is essential before installing the new drive(s) on a new NAS.

  28. I plan on buying either a DNS-323 or a DNS-325, i was wondeirng. In the reviews they said that you can’t copy or paste any other files or read once it s in use while ur doing something.

    Also will this show up as drive on “MyComputer” on windows? or show up on the mac with no extra software?

    The speed of the DNS-323 is crummy, but i heard you could install quite a bit of software on it. This will be my first NAS, i would like to stream HD movies etc. 🙂

    1. I had a DNS-321 (little cousin to 323) and found it too slow. The DNS-325 has been substantially faster for me. I recommend you go for that. It’s a good deal if you get one on sale.

      The DNS-325 will show up in Windows as “DNS-325” IIRC by default and the shared volumes will show up as Volume_1 and Volume_2 (if you have two separate drives.) You can then map them to network drives. On a Mac you can use the AFP server and the DNS-325 shows up like a Mac server. Both work great for me.

      1. Thanks for the info. I Purchased the DLINK 325 from A store in the UK, and now im thinking of upgrading the stock firmware to the latest,but it seems like someone tried it, and had an issue, because as per the EU site there is no firmware update, but as per US site, the latest firmware dated 2012 is there. :S

        I read someone say that if you install a firmware from a different region, you could brick it.. :S

  29. I have fun_plug 0.7 install on my new DNS-325, but for some reason, it loses the root password on every reboot. I did download and run the store-passwd.sh from wolf-u.li and it appears to be successful:

    Saving Userdata to /usr/local/config/

    Anyone have any ideas?

  30. I’m having trouble with ‘wget’ and ‘rsync’ because my NAS isn’t reaching outside the network.

    For example:

    wget http://wolf-u.li/u/233 -O /ffp/start/optware.sh
    --2012-10-07 09:25:33-- http://wolf-u.li/u/233
    Resolving wolf-u.li... failed: Name or service not known.
    wget: unable to resolve host address `wolf-u.li'

    –> same is true for ‘rysnc’

    Can anyone provide some information on what the NAS network settings need to be so that the NAS can ping outside the network. I’ve tried disabling the firewall but that didn’t change anything.

    My NAS (Static IP) is wired directly to my router (Buffalo with DD-WRT) which is running DHCP. All other devices on the network can access the internet.

    From mac:
    ping www.google.com
    PING www.google.com (74.125.141.106): 56 data bytes
    64 bytes from 74.125.141.106: icmp_seq=0 ttl=47 time=28.333 ms
    64 bytes from 74.125.141.106: icmp_seq=1 ttl=47 time=19.278 ms
    64 bytes from 74.125.141.106: icmp_seq=2 ttl=47 time=18.579 ms

    From NAS:
    ping www.google.com
    ping: bad address 'www.google.com'

  31. I have funplug set up on a single standard volume HDD. I want to add another standard volume HDD. Can I insert the new drive and format it via the web interface, without removing the current drive with funplug installed? The manual says that both drives are formatted when you use the web interface formatting tool.

    I would just remove the current drive, insert the new drive, format it, then insert the current drive again, but I am afraid my funplug installation will be corrupted if I do this.

    Thanks a lot for writing the articles on this page, by the way. They were very helpful when I set up my DNS-325 several months ago.

    1. Please disregard the post above. I’ve formatted the new drive, and funplug is working now, after a slight hiccup. I’ve left the message below for the benefit of others who may run into the problem I had.

      My first HDD was installed in the left slot as Volume_1, and it had funplug and other applications on it. I installed my second HDD as Volume_2 in the right slot, leaving the first HDD in the left slot. With the drives in this configuration, funplug would not load at boot. Swapping the HDD slots fixed the problem. Funplug loads at boot with the Volume_1 HDD with funplug installed in the right slot,

  32. I’m finding Samsung TV’s DLNA support limited in the number of video file types it can play off of my DNS-325 drive.

    Is there an official plugin or a Fonz package or even a Java applet with better conversion support?

    I’m thinking it would replace the D-Link “UPnP” plugin – or maybe it could add more decoders to it?

    Thanks in advance!

  33. I have used the dns-323 for several years and chose to upgrade to the dns-325. The dns-325 has few options for creating addition shares and ftp accounts than the dns-323. The dns-325 REQUIRES that a second hard drive be install for additional shares. Additions shares can only be created on Volume_2. For example, you can not have Volume_1/my/share as a share but you can have Volume_2/my/share.

    If you want a faster NAS with fewer feature options than the dns-323 the dns-325 is for you.

    After being a loyal customer with all my network gear from D’link I will no longer buy products from D’link for fear of being feature downgraded when buying an upgrade.

    If you want a better product at the same price look at the Synology DS212j.

    1. Hi I_Fly_Away,

      i’m really sorry but i cannot see this error on my DNS-325 where i have only one drive installed? I can add Shares for this drive as well?

      Best Regards,
      Uli

  34. I am trying to back up my computer through the LAN backup. I am inputting my IP address at it is requiring in the URL, but it keeps saying failed. The manual shows it in a different format that the UI is requiring but no success. I have entered it every way I know how. Either there is an issue with the firmware or the instructions are not clear on what I have to do. Has anyone got this to work? I have a MAC and don’t want to use the Time Machine backup.

  35. I’m really starting to wish I had just gotten a Drobo. I still can’t connect to my DNS-325 via AFP. If I try to log in as Admin through the Finder, I get a message that says I need to change my password. If I try to log in as a user, then the connection just spins indefinitely and never connects. This thing is a pain in the ass.

    1. After reformatting and resetting to factory defaults, I can once again connect via AFP. Going to start re-adding my data and I’ll see how long this lasts.

    2. Hi there, I have the same issue. After updating to MacOSX Yosemite I cannot connect my automatic backup to my DNS-325. It says I need to change my passwork when I try to use the admin account to log on.
      Have you managed to fix this?
      Thanks!!

  36. Hi all,
    I recently got DNS-325, inserted 2 1TB HDDs, and created RAID1 volume_01 full size (1TB). I can not share folders inside the volume, only the volume itself. I created folders ie. Music, Videos… but I dont see them in selection when choosing network share.

    Any ideas? Tnx

    1. Hi,

      Exactly the same for me !
      Two 2To HDD and the last firmware.

      I’ve created directories with my mac, I can see those with D-Link explorer, but nothing to share only Volume_1

      Thanks

      Pat

  37. Hi!

    I have a dns-320 with fun plug 0.7. I have installed subversion, but i want start, i got this error: svnserve: E000022: Can’t create server socket: Invalid argument
    I read here, this bug is fixed by uli (kernel >= 2.6.27.)!
    What am I doing wrong?
    sorry my english

  38. I just bought DNS-325. I put 2 drives in it with existing NTFS partition full of data. It seems I can not set it up without reformatting, is that correct or is there a way?

    Thanks and all the best
    bub

  39. Hi there i just formatted after a hardware upgrade and now my windows is asking me for a password to access my DNS anyway i can get rid of this and access it via the file manager like i used too? as of now i can’t access it at all except via the web browser

  40. Hi there,
    I have been using the DNS-325 for a while. I have two problems:
    1. photo’s do not display when viewed using the smart sharing app (i.e. on a smart TV or smart phone), but mp3 and videos are fine on the share. I tried upgrading to f/w 1.04b05 hoping that it would solve the problem. Then all files were not visible anymore, except through direct network share, so I rolled back.
    2. The drive(s) shows that the Raid1 integrity is degraded. This never happened before the f/w update and happens even with going back to 1.03. Repairing the Raid1, works for a while and files are visible on the smart share, but is lost again. If the HDD is damaged, is it possible to determine which of the two drives is giving the problems?
    Thanks for the help

  41. My D-link NDS-325 is death because thunder, and now I want to put hard drives from old death, to new execly the same nas server. How can I do that without formating hard drives. I have two 1Tb drives in raid1 mirror.

  42. I’ve just picked up a DNS-325 and quite quickly noticed the limitations of the supplied media server implementation, so I was considering installing Twonky on there as it seems to be a good option.

    Has anyone here seen this comment on the d-link forums with a link to Twonky as an addon from the russian d-link site? There are also other addons listed too.

    http://forums.dlink.com/index.php?topic=54848.msg214450#msg214450

    It states: “I also suggest the following russian D-Link page ( http://dlink.ua/dns_addons – translation from russian http://translate.google.com/translate?hl=en&sl=ru&tl=en&u=http%3A%2F%2Fdlink.ua%2Fdns_addons&sandbox=1 ) that contains all addons for DNS-325…
    I am testing some of them (with firmware 1.04b), such as:

    6) twonkymedia server : an alternate dlna server, just another world if compared with built-in dlna server. For me it is a pleasant surprise, I confirm it is wonderful and very useful.”

    I was wondering if anyone had any knowledge of this and whether it is a viable option for all DNS-325 owners to get Twonky?

    1. I decided to give the Twonky add-on from the link ago (http://dlink.ua/dns_addons), it presents options for DNS-325, DNS-327L and DNS-345.

      After downloading it and then logging onto the DNS-325 interface I added the add-on in the normal way and it shows up in the Applications tab on the ShareCentre interface. Enabling it and the launching the Twonky Interface shows that it is running Version: 7.2.1 of Twonky and so far it all seems to working really well.

      Unlike the build in media server, Twonky is showing all my music to upnp clients and seems to server movies well too.

      Its early days but so far I am pleased and it might be an easier way for those of you who just want the Twonky install to get this without the worry of the full Funplug install.

  43. Hi,
    I use Twonky server for over 3 years on my 325.
    But until then I did not know there was a built for that addon!
    I only use my 325 as to DLNA multimedia for my family, so I installed a debian squeeze in my 325 and found a way to install Twonky 7, because there was no help.
    I struggled a bit but I found and it works very well, it is a marvel.

  44. I have a DNS 325 with Twonky 7.0.9 connected to a LG blu-ray player playing though a TV. Everything is working and we can see the DNS and Twonky pages but the library index does not show/load on the TV to be able to pick a movie. This has happened before and I hard reset the DNS and it worked. This was about a year ago. I did the hard reset this time and it did not fix the problem.

    Help….what can I do????

    1. log into your server. click on management, then on application management, select upnp server and click refresh all. it should rescan all of your media files. I have had the same issue.

  45. Hi all, I have DNS 325 and I have installed funplug. I have managed to enable PHP on built-in lighttp web server, and I have noticed that there is also a built-in mysql server. However, I am not able to use it. First of all, I don’t know the username/password for the built-in database.

    Has anyone had experience with the built-in mysql server?

    One more question: which application/service uses built-in mysql? Could I install ffp-based mysql and run it instead of built-in one?

  46. Hi, guys!
    I have trouble with hard reset dns-325.
    I don’t have any idea about firmware version, but in all manuals write that needs to hold the reset button at least 5 or 8 seconds then device is powered up. But it don’t have any effect.
    I hold reset button that time, and more longer, but no effect any time.
    After that I start trying standard D-Link methods of hard reset for routers and APs, but still no luck.
    Please give somebody any idea for hard reseting this device. Pizdets, narkhuy, blja!
    Sorry for my English. I from Ukraine.

  47. my dns-325 is no longer seen by the domain controller, running server 2008. I have been able to perform file copy to it over 100 times in the last 2.5 years and copy file copy to it from our new Exchange server. Any ideas?

    Thanks.

  48. Hi there,

    I have been using my DNS-325 as target for backup of my Macbook pro via the TimeMachine functionality in MacOSX.
    I have recently upgraded to Yosemite (MacOSX version) and now I am not able to connect to the share on my DNS-325.
    When selecting the share for backup I am prompted for user name and pw. Once input it processes this for a while and informs that it is not able to connect to the share.
    Firmware version on DNS-325 is 1.05.
    Does anybody know what might work for me to restart my backup successfully?
    Thanks,

    Anders

  49. Pingback: Dns-321 Firmware |

Leave a Reply

Your email address will not be published. Required fields are marked *